JumpStart HOWTO
From My Admin Page
Solaris Jumpstart Howto
Here's a procedure in makig a Solaris jumpstart server. # mkdir /jumpstart/image # mkdir /jumpstart/config # mkdir /jumpstart/share # lofiadm -a /var/tmp/Solaris10_u5_1108.iso /dev/lofi/1 # lofiadm /dev/lofi/1 /var/tmp/Solaris10_u5_1108.iso # svcadm disable volfs # mkdir -p /cdrom/cdrom0 # mount -F hsfs -o ro /dev/lofi/1 /cdrom/cdrom0 # cd /cdrom/cdrom0/Solaris_10/Tools # ./setup_install_server /jumpstart/image Verifying target directory... Calculating the required disk space for the Solaris_11 product ... output skipped ... # cd / # umount /cdrom/cdrom0 # lofiadm -d /dev/lofi/1 # lofiadm Block Device File # cd /jumpstart/image/Solaris_10/Misc/jumpstart_sample # cp ./check /jumpstart/config # cp /etc/dfs/dfstab /etc/dfs/dfstab.org # vi /etc/dfs/dfstab +------------------- | share -F nfs -o ro,anon=0 /jumpstart/config | share -F nfs -o ro,anon=0 /jumpstart/image | share -F nfs -o ro,anon=0 /jumpstart/share # vi /etc/dfs/dfstab +------------------- | share -F nfs -o ro,anon=0 /jumpstart # svcadm enable nfs/server # shareall # vi /jumpstart/config/sysidcfg +------------------------------ | system_locale=en_US | timezone=MET | name_service=NONE | terminal=dtterm | timeserver=localhost | root_password="WybF.D5GwZnz2" | network_interface=primary { netmask=255.0.0.0 protocol_ipv6=no default_route=127.0.0.1} | security_policy=NONE | nfs4_domain=dynamic # vi /jumpstart/config/sun4u_profile +----------------------------------- | install_type initial_install | system_type standalone | partitioning explicit | filesys any 1024 / | filesys any 1024 /usr | filesys any 1024 /var | filesys any 1024 /opt | filesys any 1024 /export/home | filesys any 256 swap | cluster SUNWCreq | package SUNWman | package SUNWbash | package SUNWless # cd /jumpstart/config # vi ./rules +----------- | karch sun4u - sun4u_profile - # ./check # vi /etc/hosts +-------------- | 10.0.0.2 pino # cd /jumpstart/image/Solaris_10/Tools # ./add_install_client \ > -e 8:0:20:0:0:02 \ > -i 10.0.0.2 \ > -s tommie:/jumpstart/image \ > -c tommie:/jumpstart/config \ > -p tommie:/jumpstart/config \ > pino \ > sun4u # svcadm enable rarp # inetconv # init 0 ok boot net - install Create a finish script # vi /jumpstart/config/sun4u_after +--------------------------------- | { | mkdir /a/server | mount -F nfs -o ro 10.0.0.1:/jumpstart/share /a/server | | cp /a/server/crontab.root /a/var/spool/cron/crontabs/root | cp /a/server/hosts.header /a/hosts | | HOSTNAME=`cat /etc/nodename` | regel=`grep $HOSTNAME /a/server/hosts.org` | echo "$regel loghost ." >> /a/hosts | grep -v $HOSTNAME /a/server/hosts.org >> /a/hosts | | mv /a/hosts /a/etc/hosts | | umount /a/server | rmdir /a/server | | touch /a/noautoshutdown | touch /a/etc/.NFS4inst_state.domain | } > /a/server.log 2> /a/server.errlog # vi /jumpstart/share/hosts.header +--------------------------------- | # | # Internet host table | # # vi /jumpstart/share/hosts.org +------------------------------ | 10.0.0.1 tommie | 10.0.0.2 pino # crontab -l > /jumpstart/share/crontab.root Update the rules file # vi rules +----------- | karch sun4u - sun4u_profile sun4u_after # ./check