HBAcheets

From My Admin Page
Jump to: navigation, search
This is a quick and dirty cheat sheet of useful 
commands for working with HBA's on Solaris. 
================================================

Use 'man' for more info on the commands. 
========================================

dladm   show-dev               	- Display NIC speeds/Duplex 
cfgadm -al                     	- Shows attached devices 
iostat -En                 	- show disks and CDroms 
luxadm probe                    - Show WWNs 
prtconf –vp | grep -i wwn 	- Show WWNs 
prtpicl -v -c scsi-fcp 		- Show WWNs

luxadm -e port 
luxadm -e dump_map /devices/pci@8,600000/SUNW,qlc@2/fp@0,0:devctl - Show WWNs


cfgadm -al 
luxadm display  50020f2300006077 		- Disk Info  and WWNs
fcinfo hba-port 				- Local Port HBA info
fcinfo remote-port -s -p10000000c961f785	- Matching remote Port Info


********** Good way ****************
bash-2.05# prtpicl -v -c scsi-fcp  | egrep '(qlc|wwn)'
  SUNW,qlc (scsi-fcp, 3f00000309)
  :node-wwn      20  00  00  1b  32  06  09  3a 
  :port-wwn      21  00  00  1b  32  06  09  3a 
  :devfs-path    /pci@8,600000/SUNW,qlc@2 
  :driver-name   qlc 
  :name  SUNW,qlc 
  SUNW,qlc (scsi-fcp, 3f00000364)
  :node-wwn      20  00  00  1b  32  26  09  3a 
  :port-wwn      21  01  00  1b  32  26  09  3a 
  :devfs-path    /pci@8,600000/SUNW,qlc@2,1 
  :driver-name   qlc 
  :name  SUNW,qlc 
  SUNW,qlc (scsi-fcp, 3f0000080b)
  :node-wwn      20  00  00  14  4f  ad  4e  b2 
  :port-wwn      21  00  00  14  4f  ad  4e  b2 
   | NAME=qlc(0) |
  :devfs-path    /pci@9,600000/SUNW,qlc@2 
  :driver-name   qlc 
  :name  SUNW,qlc